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Chapter 1 การน าข้อมูลเข้าสู่โปรแกรม Excel (import data) 

 

บทแรก มาเรียนการน าข้อมูลเข้าสู่โปรแกรม Excel กันก่อนฮะ วิธีง่ายท่ีสุดคือ 

copy แล้ว paste หรือให้เราไปท่ีแท๊บ Data > Get External Data > From 

Text ได้เลย กรณีน้ีคือเราจะน าเข้าข้อมูลจากไฟล์ Excel, CSV, txt อื่นๆ Excel 

จะป๊อปอัพหน้าต่างใหม่ให้เรา browse หาไฟล์ท่ีเราต้องการ import ได้เลย 

 

เม่ือเราเจอไฟล์ท่ีต้องการแล้ว ให้เรากด Import ได้เลยครับ Excel จะแสดง

หน้าต่างข้างล่างข้ึนมา ให้เราเลือกดังน้ี 

 

• ปกติเราจะเลือกแบบ Delimited ส าหรับไฟล์ข้อมูลแบบ text ท่ีส่วนใหญ่

ใช้ comma “,” ในการแบ่งคอล่ัม (separate columns) 

• ถ้าแถวท่ีหน่ึงของข้อมูลเราเป็นช่ือตัวแปรในแต่ละคอล่ัม ให้เราต๊ิกช่อง My 

data has headers ด้วยนะครับ เสร็จแล้วกด next ต่อได้เลย 
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หน้าถัดมา ด้านซ้ายบนของหน้าต่างจะมี Delimiters ให้เราเลือกได้ 5 แบบ วิธีการ

เลือกก็ง่ายๆ ให้เราดูท่ี Data preview ในช่องด้านล่างได้เลย จะเห็นตอนน้ี

ไฟล์ข้อมูลของเราใช้ comma “,” ในการแบ่งคอล่ัมอยู่ (ซ่ึงปกติคอมม่าถือเป็นค่า

เริ่มต้นส าหรับไฟล์ text ท่ัวไป โดยเฉพาะไฟล์ CSV ท่ีเราใช้กันเยอะมาก) ให้เราต๊ิก 

เลือก comma ตรง delimiters ได้เลยครับ แล้วกด Finish 

 

Excel จะถามต่อว่าเราจะเอาข้อมูลไป

วางไว้ตรงไหน สามารถเลือกวางได้ท่ี 

Existing worksheet หรือจะไปวางท่ี 

New worksheet เลยก็ได้ เสร็จแล้ว

กด OK ได้เลยครับ 
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Chapter 2 การจัดเรียง กรองข้อมูล และกรองข้อมูลข้ันสูง (sort & filter) 

 

พอเรา import data เป็นแล้ว มาลองดูวิธีการกรอง (filter) และจัดเรียงข้อมูล 

(sort) กันดีกว่าครับ เริ่มจากการ Filter ก่อน โดยเอาเม้าส์ไปคล๊ิกท่ีข้อมูลท่ีเรา 

import เข้ามาแล้วตรงไหนก็ได้ แล้วไปท่ีแท๊บ Data แล้วกดท่ีไอคอน Filter  

เราจะเห็นปุ่มหัวลูกศรโผล่ข้ึนมาท่ีแถวท่ีหน่ึงท่ีเป็นช่ือตัวแปรของเราทุกคอล่ัมเลย 

ดังแสดงในรูปด้านล่าง ถ้าเรากดท่ีหัวลูกศร เราสามารถเลือกฟลิเตอร์ข้อมูลเราได้

ง่ายๆเลยครับ 

 

ถัดมาเรามาลองจัดเรียงข้อมูล Sort Data กันบ้างฮะ ไปท่ีแท๊บ Data เหมือนเดิม

เลย แล้วกดท่ีไอคอน  เพ่ือเรียงข้อมูลจากน้อยไปมาก (แบบ Ascending) หรือ

กด  เพ่ือเรียงข้อมูลจากมากไปน้อย (แบบ Descending) 

 

แต่ถ้าอยากจะ Sort ข้อมูลแบบละเอียดและ Sort หลายๆเลเวล (หลายตัวแปร

พร้อมกัน) ให้เรากดท่ีไอคอน  custom sort ได้เลยครับ Excel จะป๊อปอัพ

หน้าต่างใหม่ข้ึนมา และ Excel จะไฮไลท์ข้อมูลท้ังหมดของเราโดยอัตโนมัติ ถ้าแถว

ท่ีหน่ึงเป็นช่ือตัวแปร (ซ่ึงส่วนใหญ่เป็นแบบน้ันอยู่แล้ว) ให้เราต๊ิกเลือก My data 

has headers ด้วยนะครับ 
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“ 

 

• กดปุ่ม Add Level เพ่ือเพ่ิมเลเยอร์ในการจัดเรยีงข้อมูล โดย Level 

บนสุดจะส าคัญมากท่ีสุดและถูกเรยีงกอ่น 

• ตรง Sort On เราสามารถเลือกได้ 4 แบบว่าจะเรียงตาม Values (ค่า

เริ่มต้น), สีของเซลล์, สีของฟอ้น หรือว่าไอคอนในคอล่ัมน้ันๆก็ได้ 

• ตรง Order เราสามารถเรียงข้อมูลในคอล่ัมน้ันตามตัวอักษรได้ท้ังแบบ 

ascending และ descending order หรือถ้าข้อมูลในคอล่ัมน้ันเป็นตัวเลข 

เราก็สามารถเรียงคา่จากมากไปน้อย หรือจากน้อยไปมากได้เช่นกัน 

 

ถ้าเราอยากจะ Sort Columns เรียงคอล่ัมจากซ้ายไปขวา หรือจาก

ขวาไปซ้าย ให้เรากดท่ีปุ่ม Options แล้วเลือก Sort left to right 
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มาลองดู Advanced Filter กันบ้างฮะ 

อันน้ีเป็นเทคนิคข้ันสูงข้ึนมานิดแต่มีประโยชน์มากๆ สมมติเรามีข้อมูลอยู่ในสาม

คอล่ัม A1:C20 โดยท่ีแถวท่ีหน่ึงเป็นช่ือคอล่ัม Fruit, Country, Price (ภาพ

ซ้ายมือ) ให้เรากดคล๊ิกขวาท่ีแถวท่ีหน่ึง แล้วกด Insert เพ่ือเพ่ิม blank row ซัก 

4 แถวด้านบนข้อมูลชุดน้ี ดังภาพท่ีสองทางด้านขวามือนะครับ 

     

ตอนน้ีเซลล์เปล่าๆ A1:C3 เราจะเขียนกฏท่ีใช้ในการ Filter ข้อมูลครับ และน่ีคือ

ตัวอย่างของการท า Advanced Filter (รูปล่าง) เราเขียนกฏ/ฟลิเตอร์ข้ึนมาสอง

ข้อครับ ข้อแรกอยู่ในแถวท่ีสอง เราอยากได้ Apple ท่ีมาจากประเทศ USA ส่วน

กฏ/ฟลิเตอร์ของท่ีสองจะอยู่ในแถวท่ีสาม เราอยากได้ Grape ท่ีมาจากประเทศ 

Australia ราคามากกว่า $20 ข้ึนไป  

 

โดยท่ี Logic ของการเขียนฟลิเตอร์น้ีคือ ฉันอยากฟลิเตอร์ (Apple AND USA) 

OR (Grape AND Australia AND >20) โดย Excel จะเข้าใจว่าฟลิเตอร์ท่ีอยู่บน
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แถวเดียวกัน จะใช้ logic ว่า AND แต่ถ้าอยู่คนละแถว (เช่น แถว 2 vs. แถว 3) 

Excel จะใช้ logic ว่า OR นะครับ ซ่ึงการฟลิเตอร์ข้อมูลปกติจะท าโลจิคแบบ OR 

ไม่ได้ 

เม่ือเราเขียนฟลิเตอร์เสรจ็แล้ว ให้เราเอาเม้าส์คลิกท่ีตารางข้อมูลท่ีเซลล์ A5 (จริงๆ

จะกดตรงเซลล์ไหนก็ได้) แล้วไปท่ีแท๊บ Data > Advanced ตามรูปด้านล่าง 

 

Excel จะเด้งหน้าต่างใหม่ข้ึนมาแบบน้ีครับ List range จะคลุมข้อมูลของเรา

ท้ังหมดท่ีอยู่ในเซลล์ A5:C24 ส่วน Criteria range ให้เราลากคลุม Filter ท่ีเรา

เขียนมาตะกี้ ในเซลล์ A1:C3 ตามรูปด้านล่าง เสร็จแล้วกด OK ได้เลยครับ 

 

ลองดูผลลัพธ์ของ Advanced Filter ได้ในหน้าถัดไปเลย 
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Well Done! 

 

เสร็จเรียบรอ้ย งานดีมากๆ ตอนน้ีคุณกรองข้อมูลข้ันสูงเป็นแล้วครบั ด้วยการใช้ 

Advanced Filter และความเข้าใจเรื่อง logic AND และ OR 

ถ้าอยากจะ Clear Filter กลับไปเหมือนตอนแรก ให้เราไปท่ีแท๊บ Data แล้วกด 

Clear นะครับ 
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Chapter 3 การปรับแต่ง number format 

 

เราสามารถปรับฟอแมทของข้อมูลใน Excel ได้หลายแบบมากๆ ไม่ว่าจะเป็น 

number, currency, accounting, date ฯลฯ โดยไปท่ีแท๊บ Home แล้วเอาเม้าส์

ไปคล๊ิกตรงลูกศรเล็กๆ (มุมขวาล่าง) ตรง Numbers ตามรูปด้านล่าง หรือกดปุ่ม 

shortcut CTRL+1 เพ่ือเปิดหน้าต่าง Format Cells 

 

Excel จะป๊อปอัพหน้าต่างใหม่ข้ึนมาให้เราปรับแต่ง Format Cells แบบละเอียด 

เราสามารถปรับ Alignment, Font, Border, Fill, Protection ได้เช่นกัน 
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Chapter 4 การต้ังช่ือ cell และใช้ช่ือในสูตรต่างๆ (define names) 

 

รู้หมือไร่? เราสามารถต้ังช่ือ Cell ใน Excel ได้ด้วยนะ แล้วก็เอาช่ือเซลล์พวกน้ันไป

ใช้เขียน Formulas ต่อได้เลย การต้ังช่ือเซลล์ท าได้ง่ายมากๆ ดูตัวอย่างข้างล่าง

ครับ สมมติเรามีเงินเดือนปี 2017 ของพนักงาน 5 คน ในช่อง A2:A6 และเรา

วางแผนปรับเงินเดือนให้พนักงานทุกคนปีหน้า +10% ในช่อง D2 

 

เราจะลองต้ังช่ือเซลล์ D2 ว่า “Increase2018” นะครับ ให้เราเอาเม้าส์ไปคล๊ิกท่ี

เซลล์ D2 แล้วพิมพ์ค าว่า “Increase2018” ในกล่องด้านซ้ายมือได้เลย 

 

คราวน้ีเรามาลองเขียนสูตรกันบ้างครับ ในเซลล์ B2 พิมพ์ว่า 

=A2+A2*Increase2018 ได้เลยครับ แล้วลากสูตรลงไปถึงเซลล์ B6 
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“ 

ข้อดีของการใช้ Name ในการเขียนสูตรคือเวลาเราอ่าน มันจะเข้าใจง่ายมากๆเลย 

แทนท่ีจะเขียนสูตรปกติแบบน้ี =A2+A2*$D$2 แทนค่า $D$2 ด้วย 

“Increase2018” จะ make sense กว่าเยอะเลย 

 

เสร็จแล้วครับ และน่ีคือการต้ังช่ือ Cell ง่ายๆใน Excel และใช้ช่ือเหล่าน้ันเพ่ือเขียน 

Formulas ต่างๆต่อไปนะครับ ถ้าอยากจัดการช่ือท้ังหมดใน workbook ของเรา 

ให้เราเข้าไปท่ีแท๊บ Formula > Name Manager ตามรูปด้านล่างได้เลยครับ เรา

สามารถ add, edit, delete ช่ือต่างๆได้ง่ายๆ 

 

 

 

  หลักการต้ังช่ือมีสองข้อหลักๆ คือห้ามข้ึนต้นด้วยตัวเลข และห้ามมี

ช่องว่าง (space) ในช่ือท่ีเราต้ัง 
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Chapter 5 ใช้งานอย่างโปร กับ 10 Functions โคตรมีประโยชน์ 

 

มาถึงการเขียนสูตรและฟงัช่ันต่างๆในโปรแกรม Excel กันแล้วครับ อย่างแรกท่ีทุก

คนต้องรู้คือการใช้ปุ่ม F4 ให้คล่องเพ่ืออ้างอิง cell ท่ีเราใช้ในการเขียนสูตร โดยใน 

Excel จะแบ่งการอ้างอิงเซลล์ (reference) ออกเป็น 2 แบบ คือ 

1. Absolute reference (กดปุ่ม F4 เพ่ือใส่ $ หน้าช่ือเซลล์) 

2. Relative reference 

ถ้าเรากดปุ่ม F4 หลายๆครั้ง 

• 1 ครั้ง เราจะได้ $A$1 แบบน้ีเรียก Absolute คือล็อคเซลล์ A1 ค้างไว้เลย

ในสูตร (ล็อคท้ังคอล่ัม A และล็อคแถวท่ี 1) 

• 2 ครั้ง เราจะได้ A$1 แบบน้ีคือการล็อคแถวท่ี 1 แต่คอล่ัมเปล่ียนได้ 

• 3 ครั้ง เราจะได้ $A1 แบบน้ีคือการล็อคคอล่ัม A แต่แถวเปล่ียนได้ 

• 4 ครั้ง เราจะกลับไปสู่ค่าปกติ A1 เฉยๆ ไม่มีการล็อคเซลล์ใดๆ 

เม่ือเข้าใจเรื่องการท า reference ใน Excel แล้ว เรามาหัดใช้ฟงัช่ันท่ีส าคัญใน 

Excel กันดีกว่า คู่มือน้ีสอนจัดเต็มกับ TOP 10+ FUNCTIONS ท่ีถ้าใช้เป็นแล้วคุณ

จะท างานใน Excel ได้รวดเร็วข้ึนแน่นอน 

 

1. IF 

ฟงัช่ันท่ีน่าจะใช้เยอะสุดแล้วครับใน Excel เราใช้ IF เพ่ือสร้างเงื่อนไข โดย syntax 

ของ IF เป็นแบบน้ีฮะ =IF(condition, if TRUE, if FALSE) 
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“ 

ในตัวอย่างเม่ือตะกี้ เราเขียนสูตรในช่อง E2 ว่า =IF(D2>30, TRUE, FALSE) ถ้า

เกิดอายุของตัวละคนมากกว่า 30 ปีข้ึนไป ให้ Excel รีเทินค่า TRUE กลับมา แต่ถ้า

เงื่อนไขไม่เป็นจริง (หรืออายุต ่ากว่าหรือเท่ากับ 30 ปี) ให้รีเทินค่า FALSE แทน  

 

 

  ส าหรับค่า TRUE หรือ FALSE ในตัวอย่างด้านบน สามารถเปล่ียนได้

นะครับ ให้เป็นค าพูดก็ได้ แต่ต้องอยู่ในเครื่องหมาย “ “ ตัวอย่างเช่น =IF(D2>30, 

“Age greater than 30 years”, “Age lower or equal to 30 years”) 

 

เราสามารถใช้ AND, OR, NOT เพ่ือสร้าง LOGIC ได้ด้วยใน IF 

มาถึงการเขียน Logic ใน Excel ท่ีเราใช้กันบ่อยๆมีแค่สามตัวคือ AND, OR, และ 

NOT ปกติเราจะใช้ฟงัช่ันพวกน้ีใน IF statements ลองดูตัวอย่างด้านล่างครับ 

เราใช้ =IF(AND(Occupation = ”Super Hero”, Age >= 40), TRUE, FALSE) 

เพ่ือสร้างเงื่อนไขสองข้อท่ีต้องเกดิข้ึนพร้อมกัน column F ถึงจะแสดงค่า TRUE 

1. Occupation ต้องเป็น Super Hero  

2. AND และ Age ต้องมากกว่าหรือเท่ากับ 40 ปี 

ผลท่ีได้คือ colunm F จะแสดงค่า TRUE เฉพาะช่อง F2 และ F4 เท่าน้ันครับ 
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2. IFS (2016) 

ถ้าเราอยากจะเขียน IF ซ้อน IF ต้องท ายังไงดี? ถ้าเราต้องมีหลาย IF ในสูตรเดียว

แบบน้ีเรียกว่า Nested IFs ครับ ซ่ึง Excel เวอร์ช่ัน 2016 มีฟงัช่ันใหม่ IFS ท่ี

ช่วยให้การเขียน Nested IFs สะดวกข้ึนมาก ตัวอย่างด้านล่างเลยครับ พิมพ์สูตร

ในช่อง E2 ว่า =IFS(Age<=30, “Young”, Age<=40, “Old”, Age<=50, 

“Mature”) เราเพ่ิงเขียนสูตรท่ีมีท้ังหมด 3 เงื่อนไขด้วยฟงัช่ัน IFS ง่ายๆเลยฮะ 

 

ถ้าเป็น Excel version ต ่ากว่า 2016 เราสามารถเขียน Nested IF ด้วยฟงัช่ัน IF 

ปกติก็ได้ครับ พิมพ์แบบน้ีได้เลย ในช่อง E2 

=IF(Age<=30, “Young”, IF(Age<=40, “Old”, “Mature”)) 

 

3. IFERROR 

เคยพิมพ์สูตรใน Excel แล้วเจอข้อความ Error หรือเปล่าครับ? เช่ือว่าทุกคนต้อง

เคยเจอมาเหมือนกัน ถ้าเราใช้ IFERROR ไปครอบสูตรท่ีข้ึน Error น้ัน เราสามารถ

ซ่อนค่า Error หรือแก้ไขข้อความน้ันได้ไม่ยากเลย ดูตัวอย่างด้านล่างฮะ สมมติเรา

พิมพ์สูตรแล้วข้ึน Error ว่า #DIV/0! เราสามารถพิมพ์สูตร IFERROR() ทับลงไป

ได้เลยแบบน้ีครับ =IFERROR( เซลล์ท่ีขึ้น error, “”) เพ่ือแทนท่ีข้อความ error 

เหล่าน้ันด้วย blank cell หรือจะเป็นข้อความว่า “it’s error” แบบน้ีก็ได้ครับ 
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4. COUNTA + COUNTIF + COUNTIFS 

ถ้าอยากนับ cell ท่ีมีข้อมูลท้ังหมดให้เราใช้ COUNTA แต่ถ้าอยากนับค่าแบบมี

เงื่อนไข เช่น คอล่ัม C มี Super Hero กี่คน? ให้เราใช้ COUNTIF แต่ถ้าอยากจะ

นับหลายๆคอล่ัมพร้อมกัน เช่น ในประเทศอังกฤษมีนักฟุตบอลกีค่น? ให้เราใช้ 

COUNTIFS (มี S ต่อท้ายด้วย) 

 

G1 = 13 นับจ านวนเซลล์ท่ีมีข้อมูลท้ังหมดในคอล่ัม B 

G2 = 4 นับจ านวน Super Hero ท้ังหมดในคอล่ัม C 

G3 = 2 นับจ านวนนัก Football ท้ังหมดท่ีอยู่ในประเทศ United Kingdom 

 

5. SUMIF + SUMIFS 

ถ้าทุกคนใช้ COUNTIF / COUNTIFS เป็นแล้ว การใช้ SUMIF (SUMIFS) ก็เป็น

เรื่องง่ายๆแล้วฮะ โดย syntax ของ SUMIF คล้ายๆกับของ COUNIFS เลย แต่

เพ่ิมมาอีกหน่ีง argument คือคอล่ัมท่ีอยากให้มันหาผลรวมให้เรา ตัวอย่างครับ 

 

G5 = 142 หาผลรวมของอายุในคอล่ัม D ถ้าเกิดเป็นคนท่ีมาจากประเทศอังกฤษ 

G6 = 43 หาผลรวมของอายุ Professor ท่ีมาจากประเทศอังกฤษ 
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6. AVERAGEIF + AVERAGEIFS 

ใช้เหมือนกับ SUMIF / SUMIFS ทุกอย่างเลยแต่เปล่ียนจากการหาผลรวมเป็นการ

หาค่าเฉล่ียแทนครับ ตัวอย่างด้านล่างเลย ในเซลล์ G8 และ G9 ตามล าดับ 

 

 

7. MAX + MIN + LARGE + SMALL 

• MAX ใช้แสดงค่ามากท่ีสดุของข้อมูลเรา 

• MIN ใช้แสดงค่าต ่าท่ีสุดของข้อมูลเรา 

• LARGE ใช้แสดงค่ามากท่ีสุดของข้อมูลเรา (เลือกต าแหน่งได้เองเลย)  

• SMALL ใช้แสดงค่าต ่าท่ีสดุของข้อมูลเรา (เลือกต าแหน่งได้เองเลย) 

ลองดูตัวอย่างในเซลล์ G11:G14 ด้านล่างครับ เราเรียงข้อมูลจากสูงไปต ่าในคอล่ัม 

D เพ่ือความง่ายในการตรวจสอบสูตรรอบน้ีนะครบั ส าหรับ MAX/ MIN ไม่น่ามี

ปัญหาอะไร ส่วน LARGE ท่ีใช้ในเซลล์ G13 = LARGE(D:D, 3) คือดึงค่ามากสุดตัว

ท่ีสามในคอล่ัม D ออกมาเท่ากับ 43  

ส่วนในช่อง G14 = SMALL(D:D, 2) คือดึงค่าต ่าสุดตัวท่ีสองในคอล่ัม D ออกมา

เท่ากับ 21 (ดูจากข้างล่างข้ึนบน) 
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8. VLOOKUP + HLOOKUP 

VLOOKUP เป็นฟงัช่ันท่ีใช้เยอะรองจาก IF เลยก็ได้ครับ ใช้ในการ lookup ค่าท่ีเรา

ต้องการจากตารางหรือฐานข้อมูลอื่นๆ โดยท่ี VLOOKUP จะไปดึงค่าจาก column 

ท่ีเราต้องการครับ (เพราะว่า V ย่อมาจาก Vertical หรือแนวต้ังน่ันเอง) ลองดู

ตัวอย่างการใช้งานด้านล่างครับ เราจะให้ Excel ไปตามหา Yaiba ให้เรา แล้วดึง

ค่า Country, Occupation และ Age ของไยบะ ออกมาให้เราครับ 

 

G3 = Japan ไยบะมาจากญ่ีปุ่น =VLOOKUP(G1, Table4, 2, FALSE) 

G4 = Samurai เปล่ียนจากคอล่ัม 2 เป็น 3 =VLOOKUP(G1, Table4, 3, FALSE) 

G5 = 26 แค่เปล่ียนจากคอล่ัม 3 เป็น 4 =VLOOKUP(G1, Table4, 4, FALSE) 

อธิบายสูตร VLOOKUP จะมีท้ังหมด 4 arguments โดยท่ี 

• Argument ท่ี 1 คือค่าท่ีเราต้องการไปหา ในตัวอย่างคือ “Yaiba” 

• Argument ท่ี 2 คือตารางท่ีเราจะให้ Excel ไปดึงค่าให้เรา 

• Argument ท่ี 3 คือคอล่ัมในตารางน้ัน 

• Argument ท่ี 4 ปกติเราใช้ FALSE เพ่ือบอก Excel ให้ดึงค่าท่ีเป็น Exact 

Match เท่าน้ัน (คือชื่อ Yaiba ต้องตรงกัน 100% ถึงจะดึงค่าออกมาได้) 

ถ้าใช้ VLOOKUP เป็นแล้ว HLOOKUP ก็ใช้เหมือนเดิมเลยครับ เพียงแต่ตอนน้ี

เปล่ียนจากการดึงค่าแนวต้ัง เป็นดึงค่าแนวนอนแทน (เพราะว่า H ย่อมาจาก 

Horizontal) แต่ฟงัช่ันน้ีใช้ไม่ค่อยบ่อยเลย เพราะ database ส่วนใหญ่ไม่ได้

ออกแบบมาให้เหมาะส าหรับการใช้ HLOOKUP ส าหรับเพ่ือนๆท่ีสนใจ กดเข้ามาดู

รายละเอียดของฟงัช่ันน้ีได้ท่ีล้ิงน้ีเลยครับ https://goo.gl/cjZO8V 

 

https://goo.gl/cjZO8V
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มาถึงสองฟังชั่นสุดท้ายแล้ว อันน้ี Advanced ขึ้นมาหน่อย 

ต่อยอดมาจากฟงัช่ัน VLOOKUP เรามาเรียนการใช้งาน MATCH คู่กับ INDEX 

เพ่ือดึงค่าทุกอย่างท่ีเราต้องการกนัดีกว่า สองสูตรน้ียืดหยุ่นกว่าการใช้ 

VLOOKUP มาก เพราะว่าข้อจ ากัดของ VLOOKUP คือการดึงค่าในตารางท่ีมี

คอล่ัมอยู่ทางขวามือของ Lookup Value เท่าน้ัน แต่จะท ายังไงถ้าเกิดค่าท่ีเรา

อยากดึงออกมาอยู่ทางซ้ายมือของ Lookup Value? ลองดูวิธีท าข้างล่างเลยฮะ 

 

9. MATCH  

เราใช้ MATCH เพ่ือระบุต าแหน่งของ Lookup Value ใน column (หรือ row 

น้ันๆ) ดูตัวอย่างการใช้ในรูปด้านล่างได้เลยครับ ตัวอย่างน้ีเราจะหาต าแหน่งของ 

Yaiba และ Iron Man ในเซลล์ B2:B13 

 

H2 = 8 แปลว่า Yaiba อยู่ในต าแหน่งท่ี 8 ในเซลล์ B2:B13 

H5 = 4 แปลว่า Iron Man อยู่ในต าแหน่งท่ี 4 ในเซลล์ B2:B13 

มาลองดู syntax ของฟงัช่ัน MATCH กันนิดนึงฮะ มันจะมีอยู่ 3 Arguments 

• Argument ท่ี 1 คือ Lookup value ท่ีอยากให้ Excel ไปหา 

• Argument ท่ี 2 คือ Column หรือ Row ท่ีให้ Excel ไปหา 

• Argument ท่ี 3 ปกติเราจะใส่เลข 0 เพ่ือให้ Excel หาค าแบบ Exact 

Match หลักการเดียวกับการใส่คา่ FALSE ในฟงัช่ัน VLOOKUP เลย 

 

10. INDEX 

ส่วน INDEX ใช้เพ่ือดึงค่าหลังจากเรารูต้ าแหน่งของข้อมูลท่ีเราอยากจะดึงแล้ว 

สมมติเราอยากจะดึง ID (ในคอล่ัม A) ของท้ัง Yaiba และ Iron Man 
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กรณีน้ีคือเราจะดึง ID ของตัวละครท่ีอยู่ในคอล่ัม A ทางซ้ายมือของช่ือตัวละคร 

VLOOKUP จะไม่สามารถใช้ได้ในกรณีน้ีครบั ต้องเปล่ียนมาใช้ MATCH + INDEX 

แทน ผลลัพธ์อยู่ในรูปด้านบนแล้วครับ 

H8 = “K08” พิมพ์สูตร =INDEX(Table5, 8, 1) เพ่ือดึงไอดีของ Yaiba 

H9 = “K04” พิมพ์สูตร =INDEX(Table5, 4, 1) เพ่ือดึงไอดีของ Iron Man 

มาดู syntax ของ INDEX กันหน่อยฮะ มีอยู่ 3 Arguments อีกแล้ว 

• Argument ท่ี 1 คือ ตาราง ท่ีอยากให้ Excel ไปดึงค่า 

• Argument ท่ี 2 คือ row index (ท่ีเราได้มาจากฟงัช่ัน MATCH) 

• Argument ท่ี 3 คือ column index คอล่ัมท่ีเท่าไร 

เราสามารถพิมพ์สูตรเต็มของท้ัง INDEX + MATCH พร้อมกันได้แบบน้ีครับ 

H8 = INDEX(A2:E13, MATCH(“Yaiba”, B2:B13, 0), 1)  

โดยท่ี A2:E13 (หรือ table 5) คือตารางท่ีเราอยากไปหาค่า ส่วนฟงัช่ัน 

MATCH(“Yaiba”, B2:B13, 0) จะ return ค่า 8 กลับมา คือบอกว่าไยบะอยู่ในแถว

ท่ี 8 ของเซลล์ B2:B13 และ argument สุดท้ายคือเลข 1 ซ่ึงก็คือคอล่ัมท่ีหน่ึงใน

ตาราง A2:E13 น่ันเอง 

ถ้าอยากจะดึงอายุของ Yaiba ก็แก้ไขสูตรแค่นิดหน่อยด้วยการเปล่ียน column 

index ในฟงัช่ัน INDEX ได้เลย =INDEX(A2:E13, MATCH(“Yaiba”, B2:B13, 0), 

5) 
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Chapter 6 ไฮไลท์ข้อมูลด้วย conditional formatting 

 

บางทีการท่ีมีข้อมูลตัวเลขเยอะๆมันก็ดูยาก วิธีท่ีจะช่วยให้เราน าเสนอข้อมูลได้ดีข้ึน 

คือการปรับแต่ง Cells ด้วยการใส่สี ใส่ไอคอน ท า heat map ฯลฯ เราต้องท างาน 

art ใน Excel บ้าง และเครื่องมือท่ีเหมาะส าหรับงานน้ีคือ Conditional 

Formatting น่ันเองฮะ ไปท่ีแท๊บ Data > Conditional Formatting จะเห็นว่า

เราสามารถไฮไลท์เซลล์ได้หลายวิธีเลย มาลองใส่สีในเซลล์ C2:C20 ด้วย 

Top/Bottom Rules > Above Average กันดีกว่าครับ ในรูปตัวอย่างด้านล่าง 

 

ค่าเฉล่ียของเซลล์ C1:C20 อยู่ท่ีเซลล์ E2 = 

$29 ถ้าตัวเลขในเซลล์ C1:C20 มากกว่า 29 

(Above Average) เราจะใส่ฟอแมทสีเขียว

ดังแสดงในรูปด้านซ้ายมือครับ ถ้าอยากจะ

แก้ไขพวกเงื่อนไข >29 หรือแก้ไขสี 

formatting ต่างๆให้เราไปท่ี Conditional 

Formatting > Manage Rules 
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Excel จะป๊อปอัพหน้าต่างใหม่ข้ึนมาให้เรากด Edit Rule ได้เลยครับ โดยเรา

สามารถเปล่ียนเงื่อนไขได้หลายอย่าง รวมถึงเปล่ียนสี Format ต่างๆได้ ตัวอย่าง

ด้านล่างเราเลือกใหม่เป็น “Use a formula to determine which cells to 

format” แล้วพิมพ์ C2<30 ลงไปในช่องสูตร แล้วฟอแมทสีใหม่ให้เป็นสีฟา้อ่อน 

กด OK เพ่ือ apply ฟอแมทใหม่ในเซลล์ C1:C20 จะได้ผลตามรูปขวามือด้านล่าง 

           

ถ้าเราอยากจะลบ Rules ท้ังหมดท้ิงให้เรากลับไปท่ี Conditional Formatting > 

Clear Rules > Clear Rule From Selected Cells เลย (หรือจะลบท้ัง 

Workbook เลยก็ได้นะครับ)  

ลองเล่นเทคนิคอื่นๆเพ่ิมได้นะครับ ง่ายๆไม่อยากเลย อย่าง Color Scales ท่ีใช้

หลักการ Heat Map ก็ไล่สีค่าต่างๆได้สวยมาก เราแนะน าให้ลอง 
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Chapter 7 การเปล่ียน themes, colors, fonts ของ workbook 

 

ไม่ชอบสีเริ่มต้นของ Excel? ไม่มีปัญหาครับ เราสามารถแก้ไข และสร้าง Theme 

สีท่ีเราชอบเองได้เลย ไปท่ี Page Layout > Theme ทางด้านซ้ายมือสุดได้เลย 

(จะเปล่ียนสีหรือฟอ้นก็ท าได้นะ) 

 

เราสามารถปรับแต่งสีและฟอ้น แล้วกด Save Theme ไว้ใช้ในอนาคตก็ได้ครับ 

ลองเข้าไปท่ี Page Layout > Colors > Customize Colors ปรับเปล่ียนสีท่ี

ต้องการ ด้านขวาจะมีพรีวิวให้เราดูด้วย ต้ังช่ือ Theme แล้วกด Save ได้เลยครับ 
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Chapter 8 การลบข้อมูลซ ้า (Remove Duplicates) 

 

การตรวจสอบข้อมูลว่ามีข้อมูลซ ้าหรือเปล่า ก็เป็นเรื่องท่ีเราควรเช็คทุกครัง้เลย 

Excel สามารถเช็คให้เราได้ง่ายมากๆ โดยลากคลุมข้อมูลของเรา (หรือ column 

ท่ีเราจะตรวจสอบ duplicates) ไปท่ี Conditional Formatting > Highlight 

Cells Rules > Duplicate Values แล้วกด OK ได้เลย 

 

ในตัวอย่างด้านบนเราอยากจะหา Duplicates (ช่ือซ ้า) ใน column A การท่ีเราใช้ 

conditional formatting จะท าให้เราเห็นช่ือซ ้าได้ง่ายข้ึนมากๆ ดังรูปด้านล่าง 

ถ้าเราอยากจะลบ Duplicates เหล่าน้ี ให้

เราไปท่ี Data > Remove Duplicates 

แล้วเช็คเฉพาะคอล่ัม Name เท่าน้ัน (น่ีคือ

เราบอก Excel ให้ตรวจสอบค าซ ้าเฉพาะ

คอล่ัมช่ือตัวละคร) 

 

 

เสร็จแล้วให้เรากด OK ได้เลย และ Excel 

จะบอกว่ามันลบออกไปกี่ case และตอนน้ี

มีเหลืออยู่ใน data ของเรากี่ case โดย 

Excel จะลบ duplicates ด้านล่างท้ิงไป

และเก็บตัวบนไว้ (ลบแถวท่ี 10/11 ทิ้ง)  
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Chapter 9 การใช้งาน group + ungroup + subtotal 

 

บทน้ีจะสอนการใช้งานการ Group column หรือ row (รวมถึง Ungroup) และ

การใช้งาน Subtotal เบื้องต้นครับ เครื่องมือท้ังหมดในบทน้ีอยู่ในแท๊บ Data 

 

ถ้าเกิดเราอยากจะ Group คอล่ัม C และ D เข้าด้วยกัน ให้เราลากคลุมคอล่ัม C 

และ D ก่อนแล้วไปท่ีแท๊บ Data > Group เราจะได้เครื่องหมาย      โผล่ข้ึนมา

ด้านบน เรามาสามารถกดท่ีปุ่ม + น้ีเพ่ือซ่อนหรือขยายคอล่ัม C และ D ได้ 

 

ถ้าเราอยากจะ Ungroup ก็ลากครอบคอล่ัมน้ันไว้ แล้วไปกด Ungroup ได้เลยครบั 

ง่ายๆ ถัดไปมาลองดูการใช้งาน Subtotal บ้างครับ 

 

   

  Subtotal ไม่สามารถใชไ้ด้กบัข้อมูลท่ีเราเกบ็ในรปูของ Table และ

ก่อนใช้งาน Subtotal เราต้อง Sort เรียงข้อมูลก่อน 
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เรียงข้อมูลก่อนท า Subtotal นะครับ 

ตอนน้ีเรา Sort ข้อมูลใน Column C เรียบร้อยแล้วครับ เรียงตามช่ืออาชีพแบบ 

Descending (เรียงจากตัวอักษร Z ข้ึนก่อน) เสร็จแล้วไปท่ี Data > Subtotal 

จะมีหน้าต่างใหม่โผล่ข้ึนมาดังรูปด้านล่าง 

 

ให้เราต้ังค่าตามน้ีได้เลยครับ 

▪ At each change in ต้ังค่าเป็น Occupation 

▪ Use function ใช้เป็นค่าเฉล่ีย (Average) 

▪ Add subtotal to ต๊ิกช่องอายุ (Age) 

▪ เสร็จแล้วกด OK ได้เลยครับ จะได้ผลลัพธ์ตามรูปด้านล่าง 

ตะกี้คือเราบอก Excel ว่าทุก

ครั้งท่ีมีการข้ึนอาชีพใหม่ จาก 

Super Hero เป็น Samurai … 

ให้เราค านวณค่าเฉล่ียของอายุ 

และแทรกแถว Average ข้ึนมา

ครับ Excel จะแทรกแถวใหม่

ทุกครั้งท่ีอาชีพเปล่ียน และมี 

Grand Average = 32.25 ใน

ช่องล่างสุด (D19)  
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Chapter 10 การสร้างตาราง (insert table) 

 

เค้าว่ากันว่ารูปแบบการเก็บข้อมูลท่ีดีท่ีสุดใน Excel คือการเก็บข้อมูลให้อยู่ในรูป

ของตารางแบบ Table Format เอาเม้าส์คล๊ิกท่ีข้อมูลของเรา แล้วไปท่ีแท๊บ Data 

> Insert > Table หรือจะกดปุ่ม shortcut บนคีบอร์ดเลยก็ได้ CTRL+T พร้อม

กันเพ่ือฟอแมทข้อมูลให้อยู่ในรูปของตาราง ถ้าแถวท่ีหน่ึงของข้อมูลเป็นช่ือตัวแปร 

ให้เราต๊ิกช่อง My data has headers ด้วยนะครับ 

 

พอเราเอาเม้าส์ไปคล๊ิกท่ีตารางของเรา จะมีแท๊บใหม่โผล่ข้ึนมาช่ือว่า Design ซ่ึงเรา

สามารถปรับแต่งหน้าตาของ Table ให้ดูดี สวยข้ึนได้ง่ายๆเลย 

 

• เราสามารถต้ังช่ือตารางของได้ท่ีช่อง Table Name (ทางด้านซ้ายมือสุด

ของแท๊บ Design และเราควรต้ังช่ือทุกครัง้) 

• ถ้าอยากเปล่ียนตารางกลับไปเปน็ Range ปกติให้กด Convert to Range 

• เราสามารถกด Insert Slicer  เพ่ือใช้ในการกรองข้อมูลเร็วโคตรๆ 
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• ข้อดีของการใช้ Table คือเราสามารถพิมพ์สูตรโดยอ้างอิงช่ือคอล่ัมใน 

Table น้ันๆได้เลยอย่างเช่น =[Experience]*[Bonus] โดยช่ือคอล่ัมต้อง

อยู่ในเครื่องหมาย [ ]  

• เวลาเราเพ่ิม new column หรือว่า new row ตัว Table จะอัพเดทพวก

ฟอแมทให้เราอัตโนมัติเลย 

• เราสามารถปรับ format ของ Table เราได้ท่ี Table Styles 

• เราสามารถสรุปผลข้อมูลใน Table ของเราด้วย PivotTable ง่ายๆเพียง

กดปุ่ม Summarize with PivotTable 

• เม่ือใช้คู่กับ PivotTable จะมีประสิทธิภาพมากย่ิงข้ึน การอัพเดทข้อมูล

ท้ังหมดเป็นไปอย่างอัตโนมัติ ไม่ต้องกลัวว่าตารางหรือชาร์ทของเราจะไม่

อพัเดทข้อมูล 

 

 

การเก็บข้อมูลในรูปแบบ Table ถือว่ามีประสิทธิภาพท่ีสุดแล้วใน

โปรแกรม Excel เพราะมันง่ายต่อการดูแล แก้ไข และอัพเดท 
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Chapter 11 การใช้งาน PivotTable เบื้องต้น 

 

พอเราเก็บข้อมูลในรูปแบบของ Table เรียบร้อยแล้ว ข้ันตอนถัดไปคือการวิเคราะห์

ข้อมูลของเราอย่างมีประสิทธิภาพด้วย PivotTable สุดยอด Tool ใน Excel เอา

เม้าส์ไปคล๊ิกท่ี Table ของเรา แล้วกดท่ีแท๊บ Design > Summarize with 

PivotTable จะมีหน้าต่างใหม่โผล่ข้ึนตามรูปด้านล่าง ลากคลุมข้อมูลของเรา 

(ปกติ Excel จะ select ข้อมูลให้เราอัตโนมัติอยู่แล้ว) แล้วกด OK ได้เลย 

 

Excel จะสร้างช้ีตใหม่ข้ึนมาให้เรา และมี

หน้าต่างด้านซ้ายโผล่มา โดยจะมีท้ังหมด 5 

ช่อง ช่องบนสุดคือตัวแปรท้ังหมดท่ีมีใน 

Table ของเรา ได้แก่ Name, Country, 

Occupation, Age ส่วนอีกส่ีช่องท่ีเหลือคือ 

• Filters เลือกตัวแปรมาเป็นฟลิเตอร์ 

• Columns เลือกตัวแปรมาเป็นหัวตาราง 

• Rows เลือกตัวแปรมาเป็น row ข้างๆ 

• Values ช่องน้ีห้ามว่าง ต้องดึงตัวแปร

มาใส่เสมอ เพ่ือบอก Excel ว่าเราจะหาค่า

อะไร? 
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จริงๆแล้ว PivotTable คือการสร้างตาราง Crosstabs น่ันเอง เอา

ตัวแปรสองตัวมาครอสกนั Column x Row 

 

ลองเลือกตัวแปรไปใส่ในช่องต่างดังน้ีครบั 

▪ Filter = Country 

▪ Columns = Occupation 

▪ Row = Name 

▪ Values = Count of Age (เอาเม้าส์ไปคล๊ิกท่ีตัวแปรน้ีในช่อง Value แล้ว

เลือก Value Field Settings แล้วเปล่ียนจาก Sum ให้เป็น Count ได้เลย) 

เราจะได้ผลออกมาตามรูปด้านล่างนะครับ ข้อมูลของเรามีท้ังหมด 12 คน ซ่ึงดูได้

จากช่อง G17 ข้อมูลของเรามีนักแสดงอยู่ท้ังหมด 2 คน (B17) นักฟุตบอลมีอยู่

ท้ังหมด 3 คน (C17) ฯลฯ  

ส่วน Filter จะอยู่ท่ีช่อง B1 เราสามารถฟลิเตอร์ประเทศให้ตารางน้ีแสดงเฉพาะ

ประเทศอเมริกาอย่างเดียวก็ได้เหมือนกัน และน้ีคือการสร้างตาราง PivotTable 

เบื้องต้นครับ แค่เลือกตัวแปรไปใส่ในช่องต่างๆ ก็สามารถท า Report เบื้องต้นได้

ง่ายๆเลย (ลองปรับ Format ของตาราง Pivot ได้ท่ีแท๊บ Design ด้านบน) 
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Chapter 12 การใช้งาน PivotChart เบื้องต้น 

 

PivotChart เป็นส่วนหน่ึงของ PivotTable ครับ ในตัวอย่างด้านล่างเราย้าย 

Country ไปอยู่ท่ี Row ส่วนช่อง Value เป็น Count of Age ปกติครับ (แค่นับ

จ านวนคนในแต่ละประเทศ) พอเราสร้างตาราง Pivot ท่ีต้องการเสร็จแล้ว ให้เราไป

ท่ีแท๊บ Analyze > PivotChart แล้วเลือกชาร์ทท่ีเราต้องการได้เลย อันน้ีเราใช้

เป็น Clustered Column Chart ได้เลยครับ 

 

กด OK เราก็จะได้ PivotChart สวยๆตามรูปด้านล่างเลยครับ สามารถปรับแต่ง

ชาร์ทของเราได้ตามปกติเลย คล๊ิกท่ีชาร์ทแล้วเลือกแท๊บ Design ด้านบน 
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ทีเด็ดอยู่ตรงน้ีครับ เราสามารถสร้าง Filter รูปแบบใหม่ท่ีเรียกว่า Slicer เพ่ือ

กรองข้อมูลแบบเร็วๆได้เลย ให้เราเอาเม้าส์คล๊ิกท่ีชาร์ทของเรา แล้วเลือกแท๊บ 

Analyze ด้านบน แล้วเลือก Insert Slicer ได้เลยครับ  

 

Excel จะป๊อปอัพหน้าต่างใหม่ข้ึนมา ให้เราเลือก Occupation มาเป็น Slicer 

ของเราได้เลย  

กล่อง Occupation ในรูปด้านล่างคือ Slicer น่ันเองฮะ เราสามารถกดเลือก

ฟลิเตอร์อาชีพได้เลย ตาราง PivotTable กับ PivotChart ของเราจะเปล่ียนตาม

ฟลิเตอร์ท่ีเราเลือกโดยอัติโนมัติ 

 

จบแล้วครับ Chapter 11 กับ Chapter 12 อยากให้คุณได้ลองใช้งาน PivotTable 

และ PivotChart เบื้องต้นครับ ท้ังสองตัวน้ีเป็นเครื่องมือส าคัญท่ีเราจะใช้สร้าง 

Dashboard ในบทถัดไป  
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Chapter 13 เทคนิคการสร้าง basic dashboard ข้ันเริ่มต้น 

 

ตอนน้ีทุกคนน่าจะใช้งาน PivotTable กับ PivotChart เบื้องต้นได้แล้วครับ เรา

สามารถสร้าง Basic Dashboard หน้าตาแบบรูปด้านล่างได้ไม่ยากเลย 

 

เทคนิคการสร้าง Dashboard 

1. คิดก่อนว่าเราอยากน าเสนอข้อมูลอะไรบา้ง Template ควรเป็นแบบไหน 

2. เม่ือคิดเสร็จแล้ว ก็เริ่มท่ีสร้าง PivotTable 

3. แล้วสร้าง PivotChart 

4. เรียกใช้งาน Slicer เพ่ือกรองข้อมูล 

5. ย้าย Chart ของเราไปอยู่ท่ีหน้า Dashboard ท่ีเราต้องการ 

6. ถ้าอยากสร้าง Chart ใหม่ ให้ท าวนลูปข้อ 2-5 อีกครั้ง 

7. เช่ือมทุกตารางและชาร์ทเข้าด้วยกันด้วย Report Connection  

ข้ันตอนท่ี 7 ให้เราเอาเม้าส์คล๊ิกท่ี Slicer ของเราแล้วกดไปท่ี Options ด้านบน 

เลือกไปท่ี Report Connection แล้วก็ท าการเช่ือม Slicer ของเราเข้ากับทุก

ตาราง PivotTable และ PivotChart ได้เลยครับ คราวน้ีเวลาเรากดเลือก

ฟลิเตอร์ท่ี Slicer ของเรา กราฟท้ังหมดจะเปล่ียนพร้อมกันหมดเลย 
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Chapter 14 การก าหนดกฏเพ่ือป้องกนัการใส่ข้อมูลผิด (data Validation) 

 

Data Validation ใช้เพ่ือป้องกนัการคย์ีข้อมูลผิด เช่น ต้องเป็นเลขจ านวนเต็ม

เท่าน้ัน ห้ามติดลบ หรือท าเป็น drop down list ฯลฯ โดยเราสามารถต้ังเงื่อนไข

ได้ท้ังหมด 7 แบบ ให้เราไปท่ีแท๊บ Data > Data Validation  

 

Excel จะแสดงหน้าต่างใหม่ข้ึนมาแบบน้ี ตรงแท๊บ Settings > Allow เราเลือก

กฏท่ีเราต้องการได้เลย ตัวอย่างเช่น List คือการก าหนดให้เซลล์ท่ีเราต้องการมี 

drop down list โผล่ข้ึนมา ให้เราพิมพ์ค าว่า Banana, Apple, Orange ลงไปใน

ช่อง B2:B4 เอาเม้าส์คล๊ิกท่ีช่อง D2 แล้วไปท่ี Data Validation เลือก List และ

ต้ังค่าตามรูปด้านล่าง 

 

อย่าลืมต๊ิกช่อง In-cell dropdown ด้วยนะครับ คราวน้ีมาลองดูผลท่ีได้กันครับ  

ในช่อง D2 จะเห็นว่ามีปุ่มลูกศรให้เรากด

ได้ พอเอาเม้าส์ไปคล๊ิกจะเห็นว่ามี List ให้

เราเลือกใช้ได้ตามท่ีเราก าหนดไว้น้ันเอง 
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Chapter 15 ค านวณค่าท่ีเราต้องการด้วย what-if analysis 

 

Excel มีความสามารถในการวิเคราะห์ผลหลายอย่างเลย และเครื่องมืออีกตัวนึงท่ีใช้

ง่าย แต่มีประโยชน์สูงคือ What-If Analysis ประกอบด้วย Scenario 

Manager, Goal Seek และ Data Table คู่มือเราจะสอนแค่สองตัวหลังนะครบั 

เวลาจะใช้งาน ให้เราไปท่ีแท๊บ Data > What-if Analysis  

 

เริ่มกันท่ี Goal Seek 

สมมติเรากู้เงินซ้ือบ้านราคา 2,000,000 บาท (ดาวน์ไปแล้ว 500,000) อัตรา

ดอกเบี้ย 5% ต่อปี กู้ระยะเวลา 10 ปี เราต้องผ่อนเดือนละ 15,909.83 บาท ซ่ึงเรา

เขียนสูตรไว้ในเซลล์ B6 (อันน้ีเราสามารถหาได้จากสูตร =-PMT(5%/12, 10*12, 

1,500,000) ใน Excel ครับ) 

 

สมมติเราอยากผ่อนเดือนละ 25,000 บาท อัตราดอกเบี้ย 5% เหมือนเดิม เรา

อยากจะรู้ว่าระยะเวลาท่ีผ่อนจะลดลงเหลือกี่ปี? แบบน้ีเราสามารถใช้ Goal Seek 

มาตอบค าถามน้ีให้เราได้เลยครับ เปิด Goal Seek ข้ึนมา แล้วใส่ค่าตามรูปด้านบน

ได้เลย Set Cell B6 to value 25000 by changing cell B4 เสร็จแล้วกด OK 

และดูเวทมนต์ของ Excel ฮะ ระยะเวลาจาก 10 ปีจะเหลือแค่ 5.76 ปีเท่าน้ัน  
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ใช้ Data Table เพ่ือปรับเปล่ียน parameter ในสูตรของเรา 

แล้วถ้าเราอยากจะลองเปล่ียนท้ังระยะเวลากู้ และอัตราดอกเบี้ยพร้อมกันเลย เพ่ือดู

ว่าเงินผ่อนต่อเดือนของเราจะเป็นเท่าไร ท าได้ไหม? ก็ท าได้ง่ายๆเลยด้วย Data 

Table ครับ ไปท่ีแท๊บ Data > What-If Analysis > Data Table 

แต่ก่อนท่ีเราจะเรียกใช้ Data Table เราต้องเซ็ทอัพ spreadsheet ของเราก่อน

ครับ ท าตามรูปด้านล่างได้เลย ในช่อง E2 พิมพ์ว่า =B6 ครับ เราแค่จะดึงสูตร 

PMT ท่ีเราเขียนไว้มาใส่ในช่อง E2 เฉยๆเป็นเหมือน scenario ต้ังต้นของเรา 

 

เสร็จแล้วในเซลล์ E3:E6 คืออัตราดอกเบี้ยท่ีเราอยากลองเปล่ียนดู (5.0%, 5,5%, 

6.0%, 6,5%) ส่วน F2:I2 คือระยะเวลากู้ท่ีเราอยากลองขอธนาคาร (10, 15, 20, 25 

ปี) เอาเม้าส์ลากคลุมต้ังแต่ E2:I6 ครับ แล้วเปิด Data Table ข้ึนมา พิมพ์เงื่อนไข

ลงไปในช่อง Row Input Cells และ Column Input Cells ตามรูปได้เลยครับ 

• Row input cells (คือค่า 10, 15, 20, 25) ให้พิมพ์ B4 ลงไปเพ่ือบอก 

Excel ว่าแนวนอนน้ีคือ ระยะเวลา ท่ีเราอยากทดสอบ 

• Column input cells (คือค่า 5% - 6.5%) ให้พิมพ์ B3 ลงไปเพ่ือบอก 

Excel ว่าแนวต้ังน้ีคือ อัตราดอกเบี้ย ท่ีเราอยากทดสอบ 

• เสร็จแล้วกด OK จะได้ผลลัพธ์ตามด้านล่างครับ 

 

$15,909.83 10 15 20 25

5.00% 15,910$     11,862$     9,899$    8,769$    

5.50% 16,279$     12,256$    10,318$    9,211$     

6.00% 16,653$     12,658$    10,746$    9,665$    

6.50% 17,032$     13,067$    11,184$     10,128$    
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Chapter 16 วิเคราะห์ผลสถิติด้วย Analysis ToolPak 

 

Analysis ToolPak เป็นเครื่องมือลับ (Add-ins) พิเศษใช้รันผลสถิติพ้ืนฐานถึง

ข้ันสูงอย่าง Regression ท่ีซ่อนอยู่ใน Excel ต้องเรียกมันข้ึนมาก่อน โดยเข้าไปท่ี 

File > Options แล้วเข้าไปท่ี Add-ins ตามรูปด้านล่าง ในช่อง Manage เลือก 

Excel Add-ins แล้วกด Go 

 

 

หน้าต่าง Add-ins ใหม่จะเด้งข้ึนมา ให้เราเลือก Analysis 

ToolPak แล้วกด OK ได้เลยครับ เวลาจะใช้งาน ให้เราไปท่ีแท๊บ 

Data แล้วกด Data Analysis ตามรูปด้านล่างได้เลย 
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คู่มือน้ีจะสอนใช้งานตัวหลักๆ ได้แก่  

• Sampling ใช้ในการสุ่มตัวอย่างจากข้อมูลของเรา 

• Independent T-Test ใช้เปรียบเทียบความค่าเฉล่ียสองกลุ่ม  

• Correlation ใช้หาความสัมพันธ์ระหว่างตัวแปรเชิงปริมาณ 

• Regression ใช้สร้างโมเดลส าหรับพยากรณ์ (Predictive modeling) 

มาเริ่มกันท่ี (Random) Sampling 

การสุ่มตัวอย่างแบบแรนดอมถือว่าเป็นคุณภาพท่ีส าคัญท่ีสุดของการศึกษา

ประชากรแบบ observational study อย่างเช่นงานวิจัยตลาด การเก็บ

แบบสอบถาม เป็นต้น ใน Excel เราสามารถใช้ Data Analysis ในการสุ่ม

ตัวอย่างให้เราได้ ตามจ านวนท่ีเราต้องการ 

สมมติเรามีข้อมูลคะแนนสอบของนักเรียน 20 คน เป็น

ผู้ชาย 10 คน และผู้หญิง 10 คน ส่วนคอล่ัม A คือ Case 

Identifier เพ่ือบอกว่าน่ีคือนักเรยีนคนท่ีเท่าไร ต้ังแต่คน

ท่ี 1 ถึง 20 คิดซะว่ามันเป็นไอดีนักเรียน  

 

ข้ันตอนการใช้งาน Sampling ให้เราเข้าไปท่ี Data > 

Data Analysis > Sampling 
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• ช่อง Input Range ให้เราเลือกเฉพาะคอล่ัม A ท่ีเป็น case identifier 

ของนักเรียนแต่ละคน A1:A21 และเช็คกล่อง Labels ด้วยเพราะว่าแถวท่ี

หน่ึงเป็นช่ือคอล่ัม 

• Sampling Method ให้เราเลือกแบบ Random และใส่จ านวนกลุ่มตัวอย่าง

ท่ีเราต้องการ ในตัวอย่างน้ีเราให้ Excel สุ่มออกมาให้เรา 5 คน 

• Output Options สามารถเลือกได้ว่าจะให้ Excel เซฟผลของเราท่ีไหน ใน

ตัวอย่างน้ีเราเซฟผลใน E1 ของช้ีตเดียวกันเลย (ถ้าอยากเซฟผลในช้ีตใหม่ก็

เลือก New Worksheet Ply และต้ังช่ือชี้ตน้ันได้เลยครับ) 

 

กดปุ่ม OK เพ่ือรันผล Excel จะสุ่มตัวอย่างออกมาให้เรา n=5 วางอยู่ในเซลล์ 

E1:E5 สรุปเราดึงรายช่ือนักเรยีนคนท่ี 13, 12, 5, 19, 15 ออกมาครับ เราสามารถใช้ 

VLOOKUP() เพ่ือไปดึงเพศและคะแนนสอบของเด็กเหล่าน้ีออกมาได้ใน step ต่อไป 
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ถัดมามาลองรัน Independent T-Test กันต่อฮะ 

 

ให้เรากลับเข้าไปท่ี Analysis ToolPak แล้วเลือก t-Test: Two Sample 

Assuming Equal Variances ภาษาคนคือ ทดสอบค่าเฉล่ียของสองกลุ่มท่ีมีการ

กระจายตัวข้อมูลเท่ากัน (หรือใกล้เคียง) เรายังใช้ข้อมูลนักเรียนของเราเม่ือตะกี้ ใน

ลองรัน t-test นะครับ โดยต้ังค่าตามในรูปด้านล่างได้เลย  

 

• Variable 1 Range: เลือกคะแนนของนักเรียนชายใส่ลงไป C2:C11 

• Variable 2 Range: เลือกคะแนนของนักเรียนหญิงใส่ลงไป C12:C21 
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• Hypothesized Mean Difference: ใส่ค่า 0 ลงไปได้เลยครับ ช่องน้ีคือ

เรามีสมมติฐานว่าคะแนนสอบของนักเรียนชายและนักเรียนหญิงไม่ต่างกัน

เลย (mean difference เลยเท่ากับศูนย์) แปลภาษาคนว่านักเรียนชายและ

หญิงเก่งพอกัน 

• Alpha: ค่าเริ่มต้นท่ี 0.05 ไม่ต้องเปล่ียนครับ ปกตินักสถิติมักใช้ alpha ท่ี 

0.05 หลายๆคนน่าจะเคยได้ยินประโยคท่ีบอกว่า p-value < 0.05 เจอผล

ซิก (เด๋วเราก าลังจะได้อ่านผลตรงน้ีด้วยกันฮะ) 

• Output Range: กดเซฟผลในช่อง E1 ได้เลยครับ 

มาลองอ่านผลกันฮะ คะแนนสอบเฉล่ียของนักเรียนชาย (variable 1) อยู่ท่ีช่อง F4 

ส่วนคะแนนสอบเฉล่ียของนักเรียนหญิง (variable 2) อยู่ท่ีช่อง G4 ผู้หญิงได้

คะแนนสอบมากกว่าผู้ชายอยู่ 25.50 – 23.40 = 2.10 แต้ม แต่เรามีสมมติฐานว่า

คะแนนสอบของท้ังสองกลุ่มเท่ากับศูนย์ เราจะ ”ปฏิเสธ” หรือ ”ไม่ปฏิเสธ” 

สมมติฐานน้ีดี (เวลาเรียนสถิติเราจะไม่ใช้ค าว่ายอมรับสมมติฐานนะครับ) 
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“ 

ให้เราดูท่ีช่อง F13 คือค่า p-value ในทางสถิติน่ันเอง โดยหลักการทางสถิติคือ

เราจะปฏิเสธสมมติฐานถ้าเกิด p-value < alpha ตะกี้เราต้ังค่า alpha = 0.05 

ตอนท่ีเรารันใช่ไหมครับ? แสดงว่าตอนน้ี p-value (0.122) มันมากกว่า alpha 

(0.05) เราจึงสรุปผลว่า 

 

      p-value > alpha เราไม่สามารถปฏิเสธสมมติฐานน้ีได้ คะแนนสอบ

เฉล่ียของนักเรียนชายและหญิงแตกต่างกันอย่างไม่มีนัยส าคัญทางสถิต ิ

 

หรือภาษาบ้านๆจะบอกว่าจากข้อมูลท่ีเราเก็บมา (based on evidence) นักเรียน

ชายและหญิงเก่งพอๆกันก็ได้ (เพราะคะแนนต่างกันแบบไม่ซิก)  

 

อ่านจบตรงน้ี ยินดีต้อนรับทุกคนเข้าสู่โลกของสถติิครบั ไม่ยากเลยใช่ป่าว? ตอนน้ี

จ าแค่ p-value < alpha เราจะปฏิเสธสมมติฐานก็พอครบั ถัดไปเราไปลองรัน 

Correlation & Linear Regression ต่อนะครับ 

 

รนั Correlation เพ่ือหาความสัมพันธ์ระหว่างตวัแปร numerical 

ไปท่ี Data > Data Analysis > Correlation 

 



41 
 

 

• Input Range: เลือกตัวแปรใส่ลงไปท้ังหมด ลากคลุมเซลล์ B1:G399 

• Grouped By: เลือก Columns เพราะตัวแปรเราแต่ละตัวเก็บในคอล่ัม 

• Labels in first row: ต๊ิกช่องน้ีด้วยครับเพราะแถวแรกเป็นช่ือตัวแปร 

• Output Range: เซฟผล correlation ท่ีเรารันในเซลล์ I1 ได้เลย 

กด OK เพ่ือรันผล เราจะได้ตาราง Correlation Matrix ดังภาพด้านล่างนะครับ 

 

การอ่านค่าง่ายมากๆ เส้นทแยงมุมในตาราง correlation matrix จะเท่ากับ 1 

เสมอ เพราะแกนต้ังและแกนนอนคือตัวแปรตัวเดียวกัน ถ้าเราอยากดูค่า 

correlation หรือตัวย่อส้ันๆใช้ตัว “r” ท่ีบอกความสัมพันธ์ระหว่าง MPG กับ CYL 

เราสามารถดูท่ีช่อง J3 ได้ค่า r เท่ากับ -0.7754 ถ้าอยากดูความสัมพันธ์ระหว่าง 

DISP กับ HP ให้ดูช่อง L5 ได้ค่า r เท่ากับ 0.87325 
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เรื่องสนุกๆของค่า Correlation  

• ค่า r จะว่ิงอยู่ระหว่าง -1 ถึง +1 โดยเราจะอ่านค่า absolute ย่ิงเข้าใกล้ | 1 | 

แปลว่าความสัมพันธ์สูงมาก 

• เครื่องหมาย +/- แค่บอกทิศทางความสัมพันธ์ของสองตัวแปรเท่าน้ัน 

เครื่องหมาย + ตัวแปรสองตัวเปล่ียนแปลงในทิศทางเดียวกัน ถ้าติดลบคือ

ตัวแปรสองตัวเปล่ียนแปลงในทิศทางตรงกนัข้ามกัน เช่น ในรูปด้านล่างจะ

เห็นว่า MPG กับ HP ค่า correlation ต้องติดลบแน่ๆ (r = -0.75829) 

เพราะแรงม้าสูงข้ึน (HP) ระยะทางท่ีว่ิงได้ต่อน ้ามันหน่ึงลิตร (Mile per 

gallon) จะลดลง make sense? 

• Correlation ใช้ได้ถ้าเกิดความสัมพันธ์ของท้ังสองตัวแปรเปน็เส้นตรง

เท่าน้ัน และไม่มี outlier ฉะน้ันเราควรดูกราฟ scatter plot ก่อนนะ 

 

หรือถ้าไม่ใช้ Analysis ToolPak เราก็สามารถหาค่า correlation ระหว่างตัวแปร

สองตัวได้ง่ายๆด้วยฟงัช่ัน CORREL() ตัวอย่างเช่นการพิมพ์สูตร 

=CORREL(B2:B399,E2:E399) ในช่อง I9 จะได้ค่า r ระหว่าง MPG และ HP 

เท่ากับ -0.75829 ดังรูปในหน้าถัดไปเลยครับ 
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จบ correlation แล้วฮะ เรามาต่อกันท่ีโมเดลสุดท้าย Regression ท่ีใช้กันเยอะ

มาก ในงาน Machine Learning/ Data Mining/ Predictive Models 

 

สร้าง Predictive Model ด้วย Linear Regression 

ไปท่ี Data > Data Analysis > (Linear) Regression จ าไว้เสมอว่าหัวใจของ 

Regression คือการสร้างโมเดลท่ีใช้พยากรณ์คา่ y ครับ เขียนเป็นฟงัช่ันได้

ประมาณน้ี y = f(x) ถ้าเรารู้ x เราก็จะสามารถพยากรณ์คา่ y ได้น่ันเองครับ โดย

เงื่อนไขหลักของการสร้าง Linear Regression (อย่างท่ีช่ือมันบอกเลย) คือมันใช้

โมเดลความสัมพันธ์ท่ีเป็นเส้นตรง และตัวแปรตามต้องเป็น numerical data 
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โมเดลแรกท่ีเราจะลองรันกันเรยีกว่า Simple Linear Regression คือมีตัวแปร

ต้น (x) แค่ตัวเดียว และมีตัวแปรตาม (y) แค่ตัวเดียวเช่นกันครับ 

 

เราใช้ข้อมูลชุดเดิมกับท่ีรันผล correlation ไปเม่ือตะกี้นะครับ เลือกตัวแปรใส่ลงไป

ใน dialog box เหมือนรูปด้านบนได้เลยครับ โดยท่ี Input Y Range คือตัวแปร

ตาม (MPG B1:B399) ส่วน Input X Range คือตัวแปรต้น (HP E1:E399) ต๊ิก 

เลือกช่อง Labels ด้วย (เพราะว่า Row ท่ีหน่ึงเป็นช่ือตัวแปร) แล้วกดเซฟผล 

Regression ของเราในช้ีตใหม่ ช่ือว่า “Simple Model” เราจะได้ผลออกมาหน้าตา

เหมือนรูปด้านล่างนะครับ มาลองอ่านผลด้วยกันฮะ 

 

ค่าสถิติตัวแรกท่ีต้องดูคือคา่ R Square ในช่อง B5 เท่ากับ 0.57499 เป็นค่าท่ีเรา

ใช้ดูว่าโมเดลเราท างานได้ดีขนาดไหนในภาพรวม ภาษาบ้านๆคือโมเดลของเรา

อธิบายค่า y ได้กี่เปอร์เซ็นต์ (ช่ือทางการเรียกว่า explained variance) โดย R 

Square จะว่ิงอยู่ระหว่าง 0-1 ค่าย่ิงเข้าใกล้หน่ึง แปลว่าโมเดลเราท างานได้ดี 
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“ 

 

ตัวถัดมาท่ีต้องอยู่ในช่อง F12 คือค่า p-value ของโมเดล โดยเราอยากเห็นค่า p-

value < alpha (0.05) ท่ีเราก าหนดไว้ครับ ถ้า p-value น้อยกว่าอัลฟา่ท่ีเราต้อง

ไว้ตอนแรก แปลว่าโมเดลเราท างานได้จริง (our model works!) 

 

และสุดท้ายให้เราดูค่า coefficient ในช่อง B17 และ B18 ครับ เพ่ือเอามาเขียน

สมการ (โมเดล) ท่ีเราสร้างข้ึนมา ได้ดังน้ี 

MPG = 39.592 + (-0.1529)*HP 

 

โดยท่ี 39.592 เราเรียกว่าค่า intercept หรือจุดตัดแกนต้ัง ส่วน -0.1529 เรียกว่า

ค่า slope (หรือความชันของเส้นตรง) แปลความหมายได้ว่า 

 

  ถ้า HP เพ่ิมข้ึนหน่ึงหน่วย (ปัจจัยอื่นคงท่ี) MPG จะลดลง -0.1529 

หน่วย โดยมีช่วงความเช่ือม่ันท่ี 95% อยู่ระหว่าง [-0.166, -0.140] 

 

y = -0.1529x + 39.592
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และน่ีคือการรัน Simple Linear Regression เพ่ือใช้สร้างโมเดลเบื้องต้นครบั 

ตอนน้ีเราจะเก็บสมการ MPG = 39.592 + (-0.1529)*HP อยู่ในใจ ต่อไปเวลาเรา

เห็นรถยนต์คันใหม่ แล้วเรารู้ว่ารถยนต์คันน้ันมีแรงม้า HP = 150 เราสามารถแทน

ค่า 150 ลงไปในสมการได้เลยเพ่ือค านวณค่า MPG (ค านวณแล้วได้ค่า MPG = 

9.01345) ซ่ึงการท า prediction ของเราอย่าลืมว่ามันมี error เกิดข้ึนมา

ตลอดเวลา ไม่มีใครทายถูก 100% ตอนน้ีความแม่นย าของเราอยู่ท่ีประมาณ 

57.4% เอง หากดูจากค่า R Square 

 

จบแล้วครับกับ Analysis ToolPak ตอนน้ีทุกคนน่าจะพอเห็นภาพว่าเราสามารถ

ท าอะไรได้อีกเยอะเลยกับโมดูลฟรตัีวน้ี correlation & regression ถือว่าเป็นพ่ี

น้องกันครับ และเราสามารถหยิบสถิติสองตัวน้ีมาใช้คู่กนัได้เสมอๆ โดยท่ี 

correlation ใช้หาความสัมพันธ์ ส่วน regression ใช้เพ่ือสร้างโมเดลท่ี quantify 

การเปล่ียนแปลงของค่า y ท่ีเกิดจากการเปล่ียนแปลงของค่า x  

 

You are now ready! 

ตอนน้ีคุณพร้อมแล้วครับ ท่ีจะท า Multiple Linear Regression ต่อไป โดยช่ือ 

“Multiple” แปลว่าเรามีตัวแปรต้น (x) มากกว่าหน่ึงตัวในโมเดลครับ แต่นอกน้ัน

อ่านค่าทุกอย่างเหมือนเดิมเลย 1) ดูค่า R Square 2) ดูค่า p-value ในตาราง 

ANOVA และ 3) เขียนโมเดลของเราโดยใช้ค่า coefficient ท่ีรันได้ 

 

Chapter 17 & 18 เราจะแนะน าการใช้งาน Developer Tools และการจ ากัดการ

เข้าถึงและใส่รหัสเพ่ือปกป้องข้อมูลส าคัญในไฟล์งานของเรา 
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Chapter 17 การสร้าง form ด้วย developer tools 

 

เราสามารถใช้ Developer Tools เพ่ือสร้างฟอร์มต่างๆได้ใน Excel ครับ ก่อนท่ี

เราจะใช้ค าส่ังต่างๆของเครื่องมือตัวน้ีได้ เราต้องเรียกแท๊บ Developer ข้ึนมา

ก่อน โดยเข้าไปท่ี File > Options > Customize Ribbon แล้วต๊ิกเลือก 

Developer ทางด้านขวามือ แล้วกด OK ครับ เสร็จเรียบร้อยครบั 

 

เวลาจะใช้งานไปท่ีแท๊บ Developer ได้เลย กดท่ีปุ่ม Insert ตามรูปด้านล่างครับ 

จะมี Form Controls (สองแถวบน) ให้เราเลือกใช้หลายตัวเลย Tutorial น้ีเราจะ

สอนใช้ตัว Check Box กับ Scroll Bar นะครับ 

 

งั้นเรามาเริ่มกันท่ี Check Box (Form Control) กันก่อนเลยฮะ 
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เราสามารถสร้าง Check Box หน้าตาเหมือนในช่อง A2:A4 ได้ง่ายๆเลย ให้เข้าไป

ท่ีแท๊บ Developer > Insert > Check Box (Form Control) ไอคอนท่ีสามจาก

ซ้ายมือแถวบนสุด แล้วกดสร้างบนช้ีตงานของเราได้เลย  

สามารถกดคล๊ิกขวาท่ี Check Box เลือก Format Control 

เพ่ือปรับแต่งค่าได้ เช่น การแสดงผลแบบ 3D-shading 

รวมถึง cell link ท่ีเราล้ิงให้ Excel แสดงค าว่า “TRUE” ทุก

ครั้งท่ีเรา check กล่องน้ันๆ หรือแสดงค าว่า “FALSE” ถ้าเรา 

uncheck  

ส าหรับ Scroll Bar ก็ใช้เหมือนกับ Check Box เลยครับ ให้เข้าไปท่ี

แท๊บ Developer > Insert > Scroll Bar (Form Control) ไอคอนท่ีสามจาก

ซ้ายมือแถวท่ีสอง แล้วกดสร้าง object ในช้ีตได้เลย 

เม่ือเราสร้าง Scroll Bar แล้วกดคล๊ิกขวาเลือก Format Control เพ่ือเข้าไป

ปรับแต่งค่าได้ตามรูปด้านล่างครับ เราสามารถต้ังค่า minimum กับ maximum 

ท่ีเราจะเล่ือนได้บนบาร์ รวมถึงต้ังค่า incremental change ว่าให้บาร์เล่ือน

เปล่ียนทีละเท่าไร ต้ังค่า cell link เป็นต้น 
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Chapter 18 การปกป้อง worksheet ของเราด้วยพาสเวิด 

 

การรักษาข้อมูลและโครงสรา้งของไฟล์ Excel เราก็ถือว่าเป็นเรื่องส าคญัครบั โดย 

Excel มีหลาย options ให้เราเลือกใช้ ไม่ว่าจะเป็น Protect Sheet, Protect 

Workbook หรือ Encrypt File งานด้วย password 

 

ไปท่ีแท๊บ Review > Protect Sheet เพ่ือล็อคช้ีตของเรา โดย Excel จะ pop-

up หน้าต่างใหม่ข้ึนมาครับ เราสามารถพาสเวิดลงไปในช่อง Password to 

unprotect sheet ได้ โดยท่ีคนท่ีมีพาสเวิดน้ีเท่าน้ันครับ จะสามารถจัดการหรือ

แก้ไขข้อมูลในช้ีตน้ันๆได้ Excel จะขอให้เราคอนเฟมิพาสเวิดสองรอบ เรียบร้อยฮะ 

 

เบื้องต้น Excel จะให้ user ท าได้แค่สองอย่างดังรูปด้านบน คือ Select locked 

cells และ Select unlocked cells 
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แต่ถ้าเราไปท่ี Review > Protect 

Workbook อันน้ีจะเป็นการล๊อคโครงสร้างของ

ไฟล์งานเราท้ังหมดเลยครับ พอกดเข้าไปปุ๊ป 

Excel จะให้เราใส่ password เหมือนเดิมเลย  

 

เม่ือเรา Protect Workbook แล้ว คนอื่นจะไม่

สามารถเพ่ิม Sheet ใหม่ได้เลย รวมถึงไม่

สามารถ Hide/ Unhide ช้ีตใดๆท่ีเราซ่อนไว้ได้

เลยครับ (มันจะข้ึนเป็นสีเทาดังรูปซ้ายมือ กด

ไม่ได้เลย) 

 

 

แต่ถ้าเราอยากจะ Encrypt File ด้วยพาสเวิดเลย แบบคนท่ีจะเปิดไฟล์ Excel เรา

ได้ต้องมีพาสเวิดเท่าน้ัน ให้เราเข้าไปท่ี File > Protect Workbook > Encrypt 

with Password อันน้ีต้องจ าพาสเวิดไว้ดีๆเลย ถ้าจ าไม่ได้ เราจะเปิดไฟล์งานเรา

ไม่ได้อีกเลยนะฮะ (พาสเวิดเป็น case sensitive ด้วยตัวพิมพ์ใหญ่เล็กมีผลนะ) 
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“ 

จบแล้วครับ เราหวังว่าเพ่ือนๆทุกคนจะได้ประโยชน์จาก Quick Reference เล่มน้ี

ครับ แนะน าติชมได้ท่ี m.me/datarockie อย่าลืมเข้าไปกด like เพจเราด้วยนะ

ครับท่ี http://www.facebook.com/datarockie กดรีวิวเพจเราด้วยจะดีมาก

เลยยย #กราบบบ ชอบกด like ใช่กด share ใส่ 5 ดาวให้เพจเราด้วยน๊ะคร้าบ 

ขอบคุณมากๆครับ! จุ๊บ 

 

   

The more I read, the more I acquire, the more certain I 

am that I know nothing. 

         Voltaire 

 

 

 

 

 

 

 

 

 

 

 

About Me  

สวัสดีครัช แอดมินเอง เรียกทอยก็ได้ เราชอบท างานดา้น data งานหลัก

คือท าวิจัยตลาด งานรองคือดแูลเพจ datarockie และสอนวันเสาร์

อาทิตย์บ้าง ชอบอ่านหนังสือ ตู้ท่ีบ้านมีเยอะมากหลายแนว แต่หลักๆคือ 

data science, programming, marketing และ decision sciences  

https://m.me/datarockie
http://www.facebook.com/datarockie

